• Vulnerability: XSS
  • Affected Software: Quiz And Survey Master (20,000+ active installations)
  • Affected Version: 6.0.4
  • Patched Version: none
  • Risk: Medium
  • Vendor Contacted: 10/25/2018
  • Vendor Fix: none
  • Public Disclosure: 02/05/2019
CVSS

6.1 Medium CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Details

The Quiz And Survey Master WordPress plugin is vulnerable to reflected XSS as it echoes the quiz_id parameter without proper encoding.

Successful exploitation allows an attacker to execute JavaScript in the context of the application in the name of an attacked user. This in turn enables an attacker to bypass CSRF protection and thus perform any actions the legitimate user can perform, as well as read data which the user can access.

Proof of Concept
http://192.168.0.103/wordpress/wp-admin/admin.php?page=mlw_quiz_results&quiz_id='"><img+src%3Dx+onerror%3Dalert(1)>
Code
quiz-master-next/php/admin/admin-results-page.php:          
<input type="hidden" name="quiz_id" value="<?php echo $_GET["quiz_id"]; ?>" />
Timeline
  • 10/25/2018 Sent advisory (no response)
  • 02/05/2019 Disclosure